
 

Coronys Latest Changes List 26-Feb-2022 

Coronys Version 22 Release Notes 
 

26-Jan-2022 – Ver: 22.4.43 
 Version 22 is released. 
 
This is the last Coronys framework version. 
The free edition has local locked unlimited developer license. 
 
Enjoy 
 
 

  



 

Coronys Version 21 Release Notes 
 

08-Jan-2021 – Ver: 21.1.0 
 Version 21 is released. 
 

10-Nov-2021 – Ver: 21.2.29 
  
 
ETS: New Command: StrReplaceInBetween 
 New Command: PrintOut 
 Extended: StrBetweenSurrounds 
 

  



 
23-Jul-2020 – Ver: 20.3.166 
 ESL Editor – Combo box to show selected word lines and jump to there. 
 ETS – Bug Fix on task timers at main task. 
 

18-Jun-2020 – Ver: 20.3.141 
 ETS – Bug fix on load last configuration. 
  Two versions of FOR command: 
  1: For i=0 To 2 -> 0, 1, 2 
  2: For i=0 Upto 2 -> 0, 1 (2 nor in range) 
License Manager – Get and release local file from client computer. 
 

11-Jun-2020 – Ver: 20.3.132 
 ETS – Optimize script execution time. 

New Object command set for JSON files. 
Load and save lookup table at JSON format. 
Command ‘OpenConnectoion’extended. 
 
 

 Coronys Center – Check for new version. 
   Install New Version. 
   Delete memory dump files 
 ESL Editor – Auto complete now searches all open documents, you can auto complete variables 

enums and other stuff from other open document. 
 
10-May-2020 – Ver: 20.3.76 

 ETS – Optimize script execution time. 
New Object command set for JSON files. 
Add variables true and false. True is replaces to 1 and false is replaced to 0. 
Add Try, Catch and EndTry block. If ESL runtime error is fired the catch part is executed. 
Inside Try block the default OnErrorDo command is not executed. 
LT_LoadTable can load CSV file with quoted fields. 
Load UTF-8 files as ascii files. 
StrLoadFromFile is extended 
StrSaveToFIle is extended 
 

 ETS-WIN – add Kill command. 
 Coronys Center – Check for new version. 
 ESL Editor – find in files extension filter can use a list of extensions. 
 
  



 
27-Nov-2019 – Ver: 19.8.9 
 ETS - Command: StrBetweenSurrounds – Helps to parse JSON strings 
           Fix close UDP port (port not released), Fix UDP data loss in high speed stream. 
  
16-Sep-2019 – Ver: 19.6.79 
 ETS – Debugger (Internals) show task CPU usage 
 Command: Task_ActiveTasksList extended 
28-Aug-2019 – Ver: 19.6.62 
 ETS – Support new number prefixes:  

0xffff – Hex Number 
0o777 – Octal Number 
0b10011 – Binary Number 

 New Command: LT_SetStrFromLine 
 Show up to 6 Charts windows 
 Show up to 6 Online View windows 
 New commands for online Views: OLV_ 
 WinShell command is extended 
 Suite: copy/paste submit time parameters 
 

 

27-Feb-2019 – Ver: 19.1.17 
 ETS – New Commands: Task_Timer, Task_Settings 
 ETS – Task Limit event queue 

Extended Commands: SysGetInternalValue 
ESL_Editor – Corrections 
 

21-Jul-2019 – Ver: 19.5.50 
 ETS – New Commands: OLV_ Commands 
 ETS – New view (On Line View) to show online data from any source. Display charts from OLV 
 ETS – Up to 6 chart windows, Up to 6 OLV windows 
  



 
22-Oct-2018 – Ver: 18.6.171 
 ETS – Add watchdog to script running. In case the script stops, it can restart the script 

automatically – see TC generate settings. 
ETS – New Commands: LT_SetValuesFromLine, Task_PrioritySet 
Extended Commands: StopTimer, Run 

10-Aug-2018 – Ver: 18.4.107 
ETS – New Commands: IPCRestart, WinTaskIsRunning, RC_Query 
Bugfix to command: LT_Loadfromquery 
Extended Commands: RC_RouteToViewer, PrintMessage 

13-Jun-2018 – Ver: 18.3.67 
ETS – Updated commands: LL_SetAt, LL_PushHead, LL_PushTail, HT_SetValue 
 The commands above allow the object queue limit. 
 

26-Apr-2018 – Ver: 18.2.48 
ETS – New commands: LT_SetCellComment, LT_GetCellComment 
 

11-Apr-2018 – Ver: 18.1.42 
ETS – New command: OnFolderChangeDo oEventData, iFolderName, iState, iESL_Cmd 
 

20-Mar-2018 – Ver: 18.1.34 
ETS – Correct memory management. 
 RC_Close command has no internal delays. 
 Correct Abort operation. 
 Update GUI interface. 
ESL-EDITOR – Drop files from file explorer. 
SUITE – Add select/unselect all to SB jobs manager. 
 

16-Jan-2018 – Ver: 18.0.7 
ETS – New command prefix is added: @AutoDeclare. It must be before the Let Command. 
 

01-Jan-2018 – Ver: 18.0.0 
Coronys framework version 18 release. 
ETS – Startup page is added. 
Change GUI style from menu. 

 
 
 

 
  



 
02-Nov-2017 – Ver: 17.9.142 

Coronys Center – add command line flag 
 The command line flag dumps the license usage string into a file. 
 Call the Coronys center from command line like this: 
 c:\ets\coronys.exe -LU “ABC.txt” 
 -LU : license usage and the file name. 

 

30-Aug-2017 – Ver: 17.9.135 
Upgrade compiler to get better performance. 
More stable exception handling. 
Code analysis is performed. 

 

20-Aug-2017 – Ver: 17.8.129 
Less memory and better performance optimization. 

13-Aug-2017 – Ver: 17.8.122 
ETS – New Command: RC_SetTerminalState 
Remove debug messages. 
Improve ETS execution speed. 
Improve internal memory management. 
SUITE – Fixes. 

 

20-Jul-2017 – Ver: 17.5.92 
ETS – NumToAscii command is extended. See help. 
 RC_OnConnectionLostDo is extended. 

LT_Create is extended. 
 *** New module is added. The module implements Performance Monitoring. 
TCP_Server – connects to CMD.exe and redirects the I/O to there. 
 

03-May-2017 – Ver: 17.3.76 
ETS – filter to DB job queue. The filter shows the queue content by station. 

 In user parameters you can make the column with to be auto adjusted or to be fixed 
size. Do it from menu: File->Settings, select "General Settings" tab, and "User 
parameters column width". 
Show DB name is status bar. 
RC_OnConnectionLostDo command is extended. The new parameter iAutoRecover if is 
set to one and the communication is lost, the communication is restored and _RetVal 
holds the object name. 

Suite – Check uncheck all job test cases flow. This is recursive to all jobs. 
 Add suite global topmost and bottommost scripts. 
 Show DB name is status bar. 
Add station with name "localhost" and the job is submitted automatically to the local 
computer. 

 

03-May-2017 – Ver: 17.3.64 
ETS – Bug fix in TCL module. 
 

20-Apr-2017 – Ver: 17.3.63 



 
ETS – New Command: RC_OnCloseDo 
This command sets an event to the close command. 
 

04-Apr-2017 – Ver: 17.3.61 
ETS – RC_OnRxDataDo is extended, now the data collecting objects; linked lists or the hash 
tables can be selected using their resource names. 
Passing invalid parameters to windows now are handled. The Coronys packager are more 
stable. 
 

27-Mar-2017 – Ver: 17.2.54 
ETS – RC view templates are updated. Open RC viewer not duplicated. 
ESL Editor – RC view templates are updated. 
 

14-Mar-2017 – Ver: 17.2.52 
ETS – Some Fixes. 
 RC_OnRcDataDO – new record type (8) is added. This record type enables to record 
entire protocol packet into linked list or a hash table. 
The command StrField is extended. 
License server is part of ETS setup. License server document is updated. 
 

05-Feb-2017 – Ver: 17.1.26 
ESL Editor – Update templates. 
 

23-Jan-2017 – Ver: 17.1.20 
ETS – New command: LT_GetValues 
The command read the values of a given line or column into lookup table to a values list. 
 

19-Jan-2017 – Ver: 17.1.18 
ETS – New command: LT_Scan 
The command scans the lookup table to find a data into the table. The result is in a pair list 
that contains the "line|column,…" format. 
 

17-Jan-2017 – Ver: 17.1.15 
ETS – New command: LT_Sort 
The command sorts the lookup table to a new destination lookup table in acceding and 
descending order. Also you can select the data type to be sorted as strings in ASCII order os 
as floating numbers. 
 

09-Jan-2017 – Ver: 17.1.7 
ETS – Runtime log filter is updated. 



 

 
Mode combo-box is added.  

Include means to include only the messages that are in the filter range. 
Exclude means to copy all the runtime log to snapshot view excluding the messages in 
the filter range. 

You can also select an existing log file; and filter it to log snapshot while the ETS is running. 
Check the Append to Snapshot view to add more filtered information to the snapshot view. 
To save the snapshot view; select it in the front; and select save from the 'Test Manager' 
menu. 
 

04-Jan-2017 – Ver: 17.1.4 
ETS – Runtime log filter is updated. Now you can filter also using a keyword. 
from the "test manager" menu, you can load old log files, filer them and add them to the 
snapshot view. 
Saving runtime log saves the current selected tab (one of: Runtime Log, Log snapshot or 
User messages). 
 

01-Jan-2017 – Ver: 17.0.1 
ETS – Ver 17 is available. 
CmdToJob – new mode is added. Mode 3 is like mode 1. It also refreshes the job tree. 

  



 

Coronys Version 16 Release Notes 
 
25-Dec-2016 – Ver: 16.5.189 

ETS – New Commands: StrAddToList, VA_Reset 
 

20-Dec-2016 – Ver: 16.5.176 
CMDtoJob.exe – New field -JRTL – job runtime log folder. 
 

18-Dec-2016 – Ver: 16.5.171 

• ETS – New command - TMRenameMessage oStatus, iID, iMessage. 
New frame: Task Table – create tasks from table. For each line in a table the task frame 
steps are executed. Each task gets the parameters from the table line. 
 

04-Dec-2016 – Ver: 16.5.160 

• ETS – Submit job is changed to Job Launcher. 
 

28-Nov-2016 – Ver: 16.5.153 

• ETS – New Command DB_Reopen. 
 

06-Nov-2016 – Ver: 16.5.149 

• ETS – Extend verbose debug messages. 
Math routines now are internal using @FX: prefix. 
Virtual array extended to hold string type. 
Tasks are extended to 255. 
Old filters are removed from workspace tree. 

• ETS_Win – WinFind command(s) are extended. It can get empty class or caption. 

• ESL Editor – New window with current working workspace. You can open the scripts from 
this window. 

• Coronys Suite – Add log files to created job. 
 

04-Aug-2016 – Ver: 16.4.103 

• ETS – The commands StrTrim, StrTrimLeft and StrTrimRight are extended. 
 

01-Aug-2016 – Ver: 16.4.101 

• ETS_Win - The main window is split to view spy and debug information in two separate 
windows. 
 

06-Jun-2016 – Ver: 16.3.81 

• ETS – New ESL Command: DeclareOnceAtCaller. 

• Suite – Uses the new ESL command.. 
 

04-May-2016 – Ver: 16.3.73 

• ETS – Care of log files in case of multi-threading. 
Have to regenerate your test cases. 



 
• Suite - Care of log files in case of multi-threading. 

 

13-Apr-2016 – Ver: 16.2.71 

• ETS – Export part of test step tree to be used as predefined test step wizard. 
 

03-Apr-2016 – Ver: 16.2.66 

• ETS – Updated ETS multi-threading. 
Show control characters in terminal and RC_Viewer. 
Create customized module to insert to sets steps (currently manually). 
Save debugger memory and resources from ETS debug window. 
ETS settings, extend the copy or move option with do nothing. 
New ESL command: Task_UpdateTMCounters. 
 

08-Mar-2016 – Ver: 16.1.52 

• ETS – Updated ETS settings. 
New chart style: StackedBar. 

• Updated framework module. 
 

25-Jan-2016 – Ver: 16.1.24 

• ETS – Insert predefined test steps wizard. 
New commands: @task:get/set variable. 
RC_VIewerOpen and RC_ViewerClose. 
Move WS global parameters to Init state. 

• Suite – New filter tree is added; it allows to define tree view for each user. 
Status bar shows the current view and the current submit mode. 

 

03-Jan-2016 – Ver: 16.0.0 

• Version 16 is released. 
 

19-Nov-2015 – Ver: 15.13.380 

• ETS New Command: TMExcludeMessageToRTL 

• ETS Copy or move runtime logs to DB storage (Valid for DB users). 

• ETS RC_Read command is extended. 

• ESL Editor – templates are updated. 

16-Nov-2015 – Ver: 15.13.375 

• ETS Basic version is available. 

• SNMP Traps are available. 
 

22-Oct-2015 – Ver: 15.12.364 

• Internal fixes. 

• ESL Editor: stretch status bar to show command help. 
 

15-Oct-2015 – Ver: 15.12.359 

• ETS: Drag and drop to selected items in TC flow. 
New Command: TMBatchGeneration 

 



 
02-Sep-2015 – Ver: 15.12.354 

• ETS: Add to flow: Insert->Test Flow as Task. 
 

24-Aug-2015 – Ver: 15.12.347 

• ETS `ChartFromLUT` command extended. 
Add two more buttons to DoDo keys. 
Add bitmap to ToDo keys. EslToDoSet iIndex, iDescription, iESL_Cmd, iColorCode, iBmpFileName 
Internal debugger shows the content of lookup table, linked list and hash table. 

• Suite: Add Copy/Paste to job flow list. 
 

09-Aug-2015 – Ver: 15.12.334 

• CMDtoJob: New mode = 2; this mode inserts a job to compile into DB to be generated by Suite. 
o CMDtoJob.pdf is updated. 

• Suite: Generates from DB job queue. New table named: coronys_jobq_togen. 
 

04-Aug-2015 – Ver: 15.12.333 

• Coronys package ready to use with windows 10. 

• ETS_Win: Extended to support UI commands with partial Name and Value. 
o Example: UICommand _RetVal, @Res:EtsWin, iCalcWin, `Get`, `Name~=Display 

is;Role=41|text;State=100000|focusable;ChildCount=0;`, `Index` 
 

02-Aug-2015 – Ver: 15.11.328 

• ETS: 
o Bug fixes. 
o Add Virtual Array (VA_) commands. These commands adds the ability to create large 

array object (up to millions). 

• ESL Editor: Updated templates. 

• Coronys Suite: support –SUS parameter. 

• CMDtoJOB.exe: add parameters to send suspended job using –SUS 

• DB Tree Items: Add new item is faster. 
 

07-Jul-2015 – Ver: 15.11.301 

• ETS: SSH module is updated. 

• ESL Editor: New templates are added. See right-click->Insert. 

• ETS_IPC_EX: now it is possible to hold a port while creating server. Use @30900. 

• CMDtoJOB.exe: add parameters to shared memory using -SP 
 

07-Jun-2015 – Ver: 15.10.278 

• ETS: Print WS called hooks to run time log window. 
In order to enable this option, go to File->Settings. At Workspace Settings TAB put to one the 
“Print Called Hooks on generated TC” option.  
At General settings you can make the docked windows to be floating. (Use only for special 
purposes). 

• ESL Editor: the templates are updated. 
 

01-Jun-2015 – Ver: 15.10.268 



 
• ETS: New settings option: "Use Script Cashing". 

In case you are using SSD disk drive, placing this option to zero, saves memory usage. 
By default this value is true. It holds the driver scripts in an ETS memory. In case of over use of 
memory, you can set this flag to zero. Setting this flag to zero saves memory but does a lot of 
disk I/O operations. 

 

14-May-2015 – Ver: 15.10.262 

• ETS: Folder Selection remembers the last path. Event data collection limited to 2000 events, it 
can be changed from settings. OnRxStringDo has new option #5, see command help.  

• Suite: new variable ST_FullJobName. Added option to select LUT from variable name. 
 

16-Apr-2015 – Ver: 15.10.240 
ETS: SNMP API is changed. 
 

12-Apr-2015 – Ver: 15.9.233 

• ETS: the command RC_Close includes built-in delay. The delay is relative to amount of running 
tasks. 
Reduce internal memory usage. 
Internal enums prefixed with EN. 

• ESL Editor: Export (save) script as HTML. 

• Applications are compiled to use 4GB memory in 64 bit platforms. 
 

31-Mar-2015 – Ver: 15.8.223 
ETS: Optimize RC_Close command. 
This command works in a background. After you use this command, the ESL interpreter continues to 
run, while a closing process is executed in a background. It means, after this command, the used port is 
still open. Therefore it is recommended to place a delay after using this command. In case of 
multitasking, the tasks continues to work in parallel but the closing process is not. It means you have to 
place tasking depended delay. To do so; there is a new internal variable: @TASK:Count that it returns 
the amount of active tasks. The recommended relay should be like: 
Delay @Task:Count + 1 * 400. 
ESL Editor: Optimize mouse operation while selecting text area. 
 

25-Mar-2015 – Ver: 15.8.218 
Coronys Center: Show alarm about large DB tables. 
Disable or set alarm limits from ETS settings dialog. 
 

23-Mar-2015 – Ver: 15.8.216 
ETS: Multi-tasking PASS/FAIL counters are updated. 
Requires regeneration of test cases. 
You can do it from menu TestManager->TC / STC Regeneration. 
 

16-Mar-2015 – Ver: 15.7.213 
Coronys package now has 3 editions: 
Demo mode: limited to: 180 variables, 3 test flows, 16 lines per flow, only main task, no charts, no jobs, 
no DB. 
Pro. Mode: only main task, no charts, no jobs, no DB, no custom menus. 



 
Ent. Mode: all options are available. 
ETS: new generic properties. See the last two items. 

 
Open from File->Settings… 
CMDtoJob: New Flag: -JDSN, Job Destination Station Name (In Suite) in format Name#Inst 
 

10-Mar-2015 – Ver: 15.6.194 
ETS: Multi-tasking new synchronization commands. 
Bug fix command: CastVarType for 64 bit values. 
Test flow remembers the last position. 
ESL editor: Saves the script at HTML format. 
 

01-Mar-2015 – Ver: 15.6.183 
License Server: License file name is renamed to CoronysLicense1.txt 
Coronys Center: License file name is renamed to CoronysLicense1.txt. 
NOTE: After upgrade, if you have a local license file or a server floating file, you can rename it to .TXT 
extension. 
 
The license file now is pure text file, it should not be any problem sending the license file over email. 

 
 

24-Feb-2015 – Ver: 15.5.166 
ETS: Multi-tasking now supports inter-task shared objects. 
ESL editor templates are updated. 
All applications: Floating windows are disabled. 
 
 

16-Feb-2015 – Ver: 15.4.144 
ETS: Multi-tasking now supports the IPC based applications. 



 
ETS_Win: Works with ETS multi-tasking. 
 
 

3-Feb-2015 – Ver: 15.3.107 
ETS: New task management functions: 
Task_SyncRegister - Register current task to synchronization group. 
It is recommended to set a short delay after registering to sync group. This is because we cannot be sure 
that all other tasks are registered before the sync point. 
Task_SyncWait - Suspend the task until current and all other tasks in a group are at the sync point. 
 
In this synchronization mode you don’t have to know the sync participants, once all registered tasks 
reaches the SyncWait point the tasks will continue to run at the same time. 
 
The utilities CmdToETS.exe and CmdToNULL.exe are not supported with ETS multitasking. Please 
deprecate these application use. 
Instead use the RC_CommandPromptSet command. 
  



 
27-Jan-2015 – Ver: 15.3.84 

ETS:  

 
 

 

New 

Button 

Edit after 

Insert 



 
25-Jan-2015 – Ver: 15.3.65 
ETS: In order to use the new multi-tasking features, you have to regenerate your test cases. 
Regenerating the test cases does not require preparing a “.BGF” file. 
Select from ETS main menu: Test Manager-> TC / STC Regeneration…; and select the test cases folder, it 
will create the generation file and regenerate all files in the selected folder, including the sub folders as 
well. In case you cancel this option, the ETS asks for a BGF file like before. 
Command: StrInBetween is extended. 
ESL variables are extended to 65535 per task. 
Tasks are extended to 63. 
Suite: Manage your task jobs from suite. See menu: View->DB Jobs Queue… 
DB: update #33, Delete unused tables. 

 
21-Jan-2015 – Ver: 15.3.48 
ETS: Prepare for multitasking/threading. 
In multi- threading the internal terminal commands and window management commands must be used 
in the main task only. 
In addition there are some particular commands that they must be locked also. See the command help. 
Suite: Add Task frame for job flow. 

 
06-Jan-2015 – Ver: 15.2.12 
ETS: Object data is moved to shared-memory area. Now you can access the object cluster data from any 
ESL task. 

  



 

Coronys Version 15 Release Notes 
 

Coronys software download now has three variations: 

Download for windows 7 and later. 
Download for windows XP (last version for windows XP 14.16.397). XP will not get new versions. 

Download last update for windows 7 and later (Usually beta versions). 

Module Changes 

Coronys 

Setup 

Coronys setup now has standard windows setup. Most of the package applications 

has digital signatures. Now you can uninstall from windows application manager. 

Warning: if you change on of the installed text file, the next setup will not update the 

file. 

Coronys 

Center 

In first time installation, after a few seconds the following window is open: 

 
Here you can select between working in demo mode or setup the new station 

information. All data is set automatically for you. You don’t have to setup like before. 

  



 
ETS There are new features for DB users and standalone users. 

Use unified dialog for passing parameters. 

 

New Commands: 
SysGetCurrentThreadCount oVal 

Chart_Command oStatus, "SetAxisRange", iCollection, iLogXBase, iMinX, iMaxX, iLogYBase, iMinY, iMaxY 

OnWinFind oStatus, iConnectionID, iIpcEvent, iCaption, iText, iClass, iMode 

Chart_Command oStatus, "SetAxisNames", iCollection, iNameX, iNameY 

DeclareResourceData oStatus, iResourceName, iClusterName, iScope, iInfo 

SetResourceData oStatus, iResourceName, iFieldName, iValue 

@ResData:ResName:FieldName 

RC_RouteToDebugView 

WinFunction oESID, iConnectionID, `ES_Create`, iScriptingTimeout 
WinFunction oStatus, iConnectionID, `ES_Delete`, iESID 
WinFunction oStatus, iConnectionID, `ES_EvaluateStatement`, iESID, iStatement 
WinFunction oStatus, iConnectionID, `ES_ExecuteStatement`, iESID, iStatement 
WinFunction oStatus, iConnectionID, `ES_Reset`, iESID 
WinFunction oStatus, iConnectionID, `ES_RunProcedure`, iESID, iProcName, iVarList 
WinFunction oStatus, iConnectionID, `ES_SetLanguage`, iESID, iLanguage 
WinFunction oStatus, iConnectionID, `RegistryDelete`, iKeyName, iValueName 
WinFunction oStatus, iConnectionID, `RegistryWrite`, iKeyName, iValueName, iType, iValue 
WinFunction oValue, iConnectionID, `RegistryRead`, iKeyName, iValueName, iDefault 
SelectFromDBTree 

LT_Clear 

 

New ESL commands Category: Resource Management Commands 

 

Deleted commands: 

LT_EnableEvents 

LT_OnSetCellDo 

 

TC flow – copy and paste test steps using ^C ^V. 

 

Updated add tree node dialog. 

 
ESL debugger has only two windows (where 6). 

The debugger remembers “debug mode”. 

More detailed DB job info dialog box. 

Update ## operator to support ULONGLONG type cast. 

file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oESID__iConnectionID___ES_Create___iScriptingTimeout
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oStatus__iConnectionID___ES_Delete___iESID
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oStatus__iConnectionID___ES_EvaluateStatement___iESID__iStatement
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oStatus__iConnectionID___ES_ExecuteStatement___iESID__iStatement
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oStatus__iConnectionID___ES_Reset___iESID
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oStatus__iConnectionID___ES_RunProcedure___iESID__iProcName__iVarList
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oStatus__iConnectionID___ES_SetLanguage___iESID__iLanguage
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oStatus__iConnectionID___RegistryDelete___iKeyName__iValueName
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oStatus__iConnectionID___RegistryWrite___iKeyName__iValueName__iType__iValue
file:///C:/Users/Coronys/ETS/Temp/Window___WEB_Management_Commands.html%23WinFunction_oValue__iConnectionID___RegistryRead___iKeyName__iValueName__iDefault


 
Add shared memory API for multi-tasking. 

Workspace settings moves to View menu and has new dialog. 

 

IAC.INI: 

Add new entry: LIC.IP 

Use this entry to set the license server IP. 

 

Obsolete ESL commands are removed. 

 

Groups in old test step trees are deprecated. 

New option in workspace settings: 

        general settings: "Auto Save Generated Test Case" 

 

DB Users: 

More detailed job execution window. 

 
Import / export your workspace tree into database. 

In DB tree you can manage several workspaces. 

Compose test case selecting test steps from both trees. 

Submit local job to run at specified time. 

 

ESL Editor New debug window is added: 



 

 
Run and debug script step by step from the editor window. 

 New tool bar for script debugging. 

 
New help window with search in online help. 

 

Coronys 

Suite 

Extend CmdToJob.exe to send jobs to Suite. 

Run jobs from job group. 

Declare Pre and Post job to run multiple jobs in several machines and wait to all jobs 

to complete and then run the post job. 

Submit job or job group to run at specified time. 

Save tree properties to file. 



 
Product 

Manager 

New Module 

License 

Manager 

Allows deletion of a license. 

License 

Viewer 

Delete a license line. 

ETS Win ETS_Win has wizards that pastes code into ESL editor. 

RC Viewer Windows are open in tile mode. 

Better communication to ETS. 

CmdToJob Submit local job to run at specified time. 

 

 

 

  



 
 
 

 

Date / Version Details 

11 Dec 2014 
14.16.396 

Run jobs after specified time. 

Deleted commands: LT_EnableEvents, LT_OnSetCellDo 

New Command: LT_Clear 

01 Dec 2014 
14.16.368 

New ESL editor online help. The help is shown as tree. The help has search window to 

search into online help. A separate help view. You can locate this view anywhere in the 

editor. 

Coronys license monitor can remove directly a license from the license list. The 

deletion sets the time-left count-down to 6 minutes. If the removed application license 

is still alive, the timer is reset back. 

It requires to update the license server application. It is backward compatible with 

version 14. 

New ETS Command: SysGetCurrentThreadCount oVal 

24 Nov 2014 
14.15.344 

Updated icons.  

Extended DB parameters size. 

CmdToJob.exe 

More info in printing job info. Minor communication fixes. 

17 Nov 2014 
14.14.335 

IAC.INI: 

Add new entry: LIC.IP 

Use this entry to set the license server IP. 

16 Nov 2014 
14.14.334 

New look to icons - flat and clean design. 

Set splash window to Suite and ESL editor. 

ETS: 

Fix ESL debugger. Run button is not flicking. 

More detailed DB job info dialog box. 

Update ## operator to support ULONGLONG type cast. 

Suite: 

Pass parameters from CmdToJob to suite in mode=1. 

27 Oct 2014 
14.12.305 

ETS: 

Edit TC tree from ETS user. 

Update Online Help. 

Add shared memory API for multi-tasking. 

Add Refresh button to Debugger Internals window. 

ESL Editor: 

Update the debug window. 

Suite: 

Correct Pre and Post job hooks. 



 
Date / Version Details 

Selection time parameters gets the default values if it activated from CmdToJob app. 

CmdToJob: 

Bug-Fix 

05 Oct 2014 
14.12.278 

ETS: 

New ESL command to display chart in logarithmic scale: 

Chart_Command oStatus, "SetAxisRange", iCollection, iLogXBase, iMinX, iMaxX, 

iLogYBase, iMinY, iMaxY 

New ESL command to catch popup windows: 

OnWinFind oStatus, iConnectionID, iIpcEvent, iCaption, iText, iClass, iMode 

The debugger shows allocated string events used by resource manager. 

Now you can import and export your workspace tree to DB tree. It allows you to 

manage several workspaces in the sane database. 

Coronys Center: 

Coronys center has new window in a first setup to define the license manager and DB 

IPs. 

Suite: 

In suite there are two new hooks to job group. PreJob and PostJob. These hooks are 

run before and after the defined jobs in a group. 

A new variable ST_RunGroup is added, it stores the running group ID. 

 

01 Sep 2014 
14.12.222 

New tool-bar is added to ESL editor. It is used to debug the script from the editor. 

 
 

The buttons from left to right: 

1. Toggle from debug (step by step) to run mode. 

2. Set / remove break point in the selected line. 

3. Open Debug Window. 

4. Set the selected line to be the next executive line (change the running 

sequence). 

5. Select a special variable like arrays or clusters or an expression and see the 

result in the status bar. 

To see the ordinary variables value just point with the mouse and a tool-tip is shown. 



 
Date / Version Details 

 
Here you can step your commands and see the changed variables in this window. 

In ETS: 

The debugger window now has only two TABS. 

Workspace settings moves to View menu and has new dialog. 

RC_PopRxData extended. 

Step by step in user macros now shows in editor. 

 

24 Aug 2014 
14.11.159 

New CoronysSetup.exe Certificated application. 

 

Indentation to Test Case Flow. To re-indent the flow  and show in the documentation 

window, click the TAB. 

Copy sections from test case flow using keyboard Ctrl+C and Ctrl+V. 

Build in support for command prompt as stream. See: 

RC_CommandPortSet And CommandPortSet. 

 

06 Jul 2014 
14.09.71 
 

Make it simpler. 

New ESL commands Category: 

Resource Management Commands 

25 Jun 2014 
14.09.54 

Ordered run time log is saved as HTML. 

The log is opened from the run time log. 

15 Jun 2014 
14.09.50 

New Command: 

GetResourceList iLT_ID 

02 Jun 2014 Use unified dialog for passing parameters. 

DB is changed. 

06 May 2014 
14.08.37 

New Commands: 

Chart_Command oStatus, "SetAxisNames", iCollection, iNameX, 

iNameY 

DeclareResourceData oStatus, iResourceName, iClusterName, iScope, 

iInfo 



 
Date / Version Details 

SetResourceData oStatus, iResourceName, iFieldName, iValue 

@ResData:ResName:FieldName 

 

29 Apr 2014 
14.07.035 

Open “Workspace Settings” for ETS User. 

02 Apr 2014 
14.07.31 

Correction copy of tree elements. 

25 Mar 2014 
14.05.022 

Dynamic event allocation. 

When using RC_OnRxStringDo command, the event number now can get the value of 

(-3). It allocates the next free event number like (-2) but the event is cleared when 

exiting the current scope. 

Set viewer default windows style to vertical. 

7 Mar 2014 
14.04.16 

RC_RouteToFIle is extended. 

25 Feb 2014 
14.04.12 

Internal Fixes 

14 Feb 2014 
14.04.010 
 

Command: RC_ConvertEscapeCharacters changed to StrConvertEscapeCharacters. 

11 Feb 2014 
14.04.008 

New Command: RC_RouteToDebugView 

Routes the communication data to Microsoft debug viewer. 

02 Feb 2014 
14.04.007 

RC_View Application freezing is corrected. 

The tree position is stored between application executions. 

26 Jan 2014 
14.03.006 

In UDP type connection: the function IpcGetServerName () return the allocated IP 

instead the computer name. 

20 Jan 2014 
14.02.005 

Correct generation jobs from group. 

The group has new field: Group ID. 

There are two new variable:  

ST_JobGroupID -> holds the Group ID, the database new field logGroupID in table 

coronys_Log_TC holds this value. 

ST_GroupCounter -> holds the TC in a group. The last running TC has the value zero. 

20 Jan 2014 
14.02.003 

New Module: Coronys Power Shell. In ETS folder find SetupCoronysPS.msi. 

Use the following script to access from ETS: 
Declare Status, ConnectionID, Answer 

OpenConnection ConnectionID, @ENV:COMPUTERNAME $ "@30670" 

AskMailslotMessage Status, Answer, ConnectionID, 10001, "dir", 2000 

Print Answer 

CloseConnection ConnectionID 

19 Jan 2014 
14.02.003 

Lookup table size extended to 2147483648 X 2147483648. 

It is only in the paper, as usual it is limited to your computer memory size. 

07 Jan 2014 
14.01.002 

New flag in workspace settings. 



 
Date / Version Details 

 
Now you have two options to where the global parameters are generated: Before the 

pretest hooks or after the pretest hooks. 

07 Jan 2014 
14.01.002 

New Commands: 

WinFunction oESID, iConnectionID, `ES_Create`, iScriptingTimeout 
WinFunction oStatus, iConnectionID, `ES_Delete`, iESID 
WinFunction oStatus, iConnectionID, `ES_EvaluateStatement`, 

iESID, iStatement 
WinFunction oStatus, iConnectionID, `ES_ExecuteStatement`, 
iESID, iStatement 

WinFunction oStatus, iConnectionID, `ES_Reset`, iESID 
WinFunction oStatus, iConnectionID, `ES_RunProcedure`, iESID, 
iProcName, iVarList 

WinFunction oStatus, iConnectionID, `ES_SetLanguage`, iESID, 
iLanguage 
WinFunction oStatus, iConnectionID, `RegistryDelete`, iKeyName, 

iValueName 
WinFunction oStatus, iConnectionID, `RegistryWrite`, iKeyName, 
iValueName, iType, iValue 

WinFunction oValue, iConnectionID, `RegistryRead`, iKeyName, 
iValueName, iDefault 

 

29 Dec 2013 
14.00.00 

New ESL Command: SelectFromDBTree  

Remove some Obsolete commands 

Extend command: InputString 

ETS_Win has wizards that pastes code into ESL editor. 

Requires license manager version 14. 
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